There's a ghost in my GUI

Hi, guys.

I have a strange thing happening to me when using SimpleFOCStudio.

I’ll set target to 25rad/s with the command T25 and the motor will go that speed for a second…and then target gets set to 0! All on its own! I can see it printing T0 in the GUI console every second! Was really happy that I finally got the app to connect and accept commands, but now I’m perplexed.

Does this sound familiar to anyone? Would be really great to know. Thanks in advance, kind souls.


@Valentine I love the video. I’m going to share that

@Kacko no one has reported this error previously, I have to say.

Maybe it’s a case of something sitting on the KB? My desk is a bit of a mess sometimes, and I’ve had the weirdest errors only to find some item of junk on my desk was pressing enter for me continously :rofl:

1 Like

I liked everything about this. Just hope I’m not up against a force like this.

No longer getting the error I was getting before. Can’t recreate it, either, so that’s good.

Turns out the command line is working, just not the “Form View” or “Tree View” space. Also getting some “libpng warning”, but I highly doubt the color profile has anything to do with what I’m seeing.

I had this problem the first time I ran SimpleFOC Studio in Tree view (which was yesterday). Every time I tried to move the motor, it immediately jumped back to its original position. Then I looked at the Command Line interface and saw that SimpleFOC Studio was sending out a steady stream of T0 commands. There was nothing resting on my keyboard (I’ve had that happen, especially with things leaning on my 3D mouse, and it’s been spooky).

I opened SimpleFOC Studio again in Tree view a moment ago and it works fine. No stream of T0 commands. Ghost was gone.

1 Like

I’m happy to hear I’m not the only one it has happened to.