Problem installing SimpleFOCStudio

I am unable to install SimpleFOCStudio as described at GitHub - JorgeMaker/SimpleFOCStudio: A GUI based in PyQT5 and PyQtGraph to configure and control SimpleFOC devices. on Windows 11.


ERROR: Could not find a version that satisfies the requirement PyQt5==5.15.9 (from versions: 5.7.1, 5.8,, 5.8.2, 5.9, 5.9.1, 5.9.2, 5.10, 5.10.1, 5.11.2, 5.11.3, 5.12, 5.12.1, 5.12.2, 5.12.3, 5.13.0, 5.13.1, 5.13.2, 5.14.0, 5.14.1, 5.14.2, 5.15.0, 5.15.1, 5.15.2, 5.15.3, 5.15.4, 5.15.5, 5.15.6)
ERROR: No matching distribution found for PyQt5==5.15.9

Any advices? @JorgeMaker: Can you please give me a hint?

Hi @user23

could you try to modify requirements.txt to change from “PyQt5==5.15.9” to “PyQt5” and see if this solves your issue ?

Thank you @JorgeMaker

I had to remove version of pyqtgraph too, leaving the requirements.txt


Installation seemed to work :slight_smile:

1 Like

Nice to hear that you solved the installation issue :slight_smile: Enjoy the tool.

Finaly installed the SimpleFOCStudio on win10 pycharm, failed to run with python 3.6.0 , with an error from the typing package , “deque”, I read it was only added in python 3.6.1 . went to 3.9 and had a problem with the pyqt5-sip , updated this and it worked. hope this helps. I tried and failed with anaconda with a fresh install of the right version for 3.6.0 , in hindsight maybe a later version may have worked.

Whilst I like the python language, it’s package management is the worst of any programming language I’ve used. This is a common issue for SimpleFOCStudio - the dependencies/docs get fixed and then some package breaks things a few months later.

Perhaps a conda.yaml which specifies (and installs) a python version with heavily pinned dependencies might make the install process a little less brittle. But a conda approach might put off python newbies.

Thanks for showing us what works for you

Not a SW engineer but Ive used pyInstaller to make windows onefile exe, GUI’s very like FOC studio, also with pyqtgraph and serial port , very fast. could this get around the python lib version problem ?,

@nanoparticle has been working on packaging the SimpleFOCStudio. I think you can try it here:

There may still be issues due to “unsigned code”, depending on your OS…