Advices on new motor

I got this small motor+sensor set:

IPower GBM2804R + AS5048A Magnetic Sensor

image image

  • Motor Model: IPower GBM2804R
  • Weight: 57g
  • RPM: 2149~2375
  • Torque (g): 250-350
  • Voltage (V): 10V
  • Cunnrent (A): 0.07
  • Configuration: 12N14P
  • Winding Turns: 0.19*1-100T
  • Resistance(Ω): 5.57Ω
  • Hollow Shaft Diameter (mm):6.5

I’m new to motor control, and even to electronics. I know I’m in dangerous territory, because of this 5.57Ω. My multimeter tells me the line resistance is around 6Ω. So, if my understanding is correct, the phase resistance is around 3Ω.

I’m using a SimpleFOCShield and I’m starting with the single_full_control_example. My code is as follow:

   // Measured voltage of my power supply (official value is 19V).
   driver.voltage_power_supply = 19.5;  

   // I took the 10V above and subtracted 1 for safety.
   motor.voltage_limit = 9; 

   // I chose 0.1V as a starting point and I plan to increase this slowly, monitoring the current.
   // I've seen this process explained somewhere on this forum.
   motor.target = 0.1;

What do you think? Am I overcautious? Or preparing for a disaster?

6Ω is not so low … but the best you can do , in my opinion, is starting with moderate values and increase to gradually controlling that everything does not get too hot.

1 Like

So I started the test as planned and got the following error:

MOT: Monitor enabled!
MOT: Init
MOT: Enable driver.
MOT: Align sensor.
MOT: sensor_direction==CW
MOT: PP check: fail - estimated pp:21.4450
MOT: Zero elec. angle: 4.11
MOT: Align current sense.
MOT: Align error!
MOT: Init FOC failed.
Motor commands sketch | Initial motion control > torque/voltage : target 0.1V.

Looking on this forum for solutions, I found out that the issue probably lies in my magnetic sensor. But before I investigate, I decided to forget about the sensor and to experiment with open loop.

So I took the open_loop_velocity_example and set the following code:

  float target_velocity = 1;
  motor.voltage_limit = 0.1;
  motor.velocity_limit = 5;

And it worked!

I progressively increased both the speed and the voltage limit, assessing the heat of the wires and L6234 with my fingers. All was going smoothly.

Then, I decided to see what measuring the current on a phase with my multimeter would look like. So I unplugged a phase to put it though my multimeter. I did a few manipulations with the wires (which I don’t remember exactly) and, at one point, I realized the motor would vibrate instead of spinning.

After a few tests, I discovered that my motor seems to be broken inside. I can not spin it by hands like I used to: there seems to be broken parts inside that prevent it to spin freely.

The broken part inside seem to relate to the “pass-through” wires. Indeed, in addition to the 3 phases, my motor has a 7-wire flat cable going through, so that you can get some signal though the motor without suffering from the rotation:
image
When I rotate the motor and I feel resistance inside, the flat cable (left/fixed part) turns instead of remaining still as it used to.

Well, that’s it for the post-mortem data. Diagnostic? :slight_smile:

I don’t know … the engines I have tested are usually difficult to open and therefore difficult to repair … I don’t know if this is your case.

If you are sure your engine is broken you can try to open it … in the worst still have a broken engine and the best might resolve the issue :slight_smile:

1 Like

Does anyone know how this “pass-through” flat cable is wired internally? What is the technical term to describe this way of passing an electric signal to the spinning part of a motor without winding the cable? I lack vocabulary in this domain to search the web efficiently…

It sounds like an unusual construction. It must have been some glue failed because of overheating.
The only way to know for sure is to take it apart.
But mind this warning :
The stator and the magnets don’t like to be separated. If you do, they want to snap back together. If your finger is in the way, then that is your problem.

1 Like

The 7 wire cable is the SPI cable to the Encoder. It is passed through the motor‘s hollow shaft because they assume you will use the motor in a Gimbal where you want the signals on the other side of the rotating element.
You can turn the plug sideways and push it through the hollow shaft to remove the cable altogether, which I would recommend doing if you don’t need the pass-through for your application.

I think I have the same motor at home. I will check when I get home. The hollow shaft should be sort of “closed” but maybe one of the SPI wires somehow got through and is caught on something.

Have you checked your mounting screws though? This is often a source of problems, because the motor casings are not very thick, and you don’t have much space to screw into. If the screws are even a little bit too long they can touch the rotor and hinder or stop its rotation, and in unfortunate cases even damage the phase windings.

I don’t think the 7-wires flat cable is the SPI cable for the provided encoder. Moreover, it is not a simple cable, but a full mechanism that uncouple one side from the other (i.e. one side can rotate while the other one doesn’t). Besides, there’s another 5-wires SPI cable for the sensor.

You nailed it! God I feel stupid. I had loosely screwed the screws, and the motor vibration must have get them down, until they touch the rotor. It works ok now. Hope I didn’t damage the windings. Thanks a lot!

You’re absolutely right! It’s a different 7-pin cable, which is passed through using a slip-ring. I never opened this motor yet, but now I took a look. I guess they provide this cable and the slip-ring for communicating with the next motor/sensor in the gimbal.
The sensor in this motor is actually connected to the smaller 3-wire plug, which means it’s using the PWM interface, and not the SPI.

Anyway, I’m very glad you solved your problem!

1 Like

Do you mean you’ve take it apart? Is it easy to do? I would love to remove the split-ring and the extra cable…

No, just the back… TBH I didn’t look further how to disassemble it… often these things are push fit and just need to be pulled off with the right amount of force. But sometimes there’s little screws hidden somewhere.

No, just the back… TBH I didn’t look further how to disassemble it… often these things are push fit and just need to be pulled off with the right amount of force. But sometimes there’s little screws hidden somewhere.

But iPower is a real company, and if their docs don’t reveal how to disassemble it, just ask their support…

1 Like