Possible bug in velocity open loop?

If you run your motor at 15rad/s for 5 minutes does it always stop at the same time?

This could be the float bug discussed here:

TLDR: floats are used in library and can overflow. It doesn’t affect all modes in the same way. Open loop velocity mode is the most noticeable.

I run motor at 15rad/s and wait… It do not stop after 5 min. But if I change velocity (after 5 min 15rad/s) to 1, 2, 3, 4, 5, 6 it not works. Only from 8 motor was rotating.
I tried run motor at 1 rad/s and wait… It stop after ~8.45.
Maybe this is float bug. But I do not know.

Perhaps if you print out motor.shaft_angle and motor.shaft_velocity it will become clearer if this is the float issue.

Did you say you were using MagneticSensorAnalog.cpp for your two sensors? This sensor has had less testing than other sensors.

Yeah, that is surely it. This is the same bug.
Ok. I’m going to resolve this right away, at least for the open-loop mode!

Hey guys,
New release is out v2.0.2 in which this bug should be taken care of.
I’ve tested with my motors and it seems to be working well :smiley:

Yes, MagneticSensorAnalog. Only one way to connect two sensors to this controller. It works…